Организация локальной сети

Работа добавлена:



Если Вы нашли нужный Вам реферат или просто понравилась коллекция рефератов напишите о Нас в любой соц сети с помощью кнопок ниже





Организация локальной сети на http://mirrorref.ru

СОДЕРЖАНИЕ

Введение……………………………………………………………………….  3

1 Анализ учитываемых информационных ресурсов и систем объекта…...  4

2 Выбор и обоснование топологии компьютерной сети и применяемых стандартов…………………………………………………………………..…. 7

3 Выбор и обоснование активного и пассивного сетевого оборудования.... 9

4 Адресация в проектируемой сети…………………………………….......  14

5 Маршрутизация в проектируемой сети…………………………………..  18

6 Расчёт основных числовых характеристик проектируемой сети………  20

7 Мероприятия по обеспечению отказоустойчивости и безопасности сети……………………………………………………………………………  24

8 Моделирование проектируемой компьютерной сети…………………...  25

Список использованных источников……………………………………….  26

Приложение А Расчет стоимости сети..…………...……………………….  27

Приложение Б Параметры конфигурации активного оборудования..…….28

ВВЕДЕНИЕ

Организация локальной сети - основополагающее звено современных предприятий, так как теперешние условия работы требуют возможности одновременного доступа нескольких сотрудников к Интернету, различным базам данных. Локальная сеть также необходима для быстрой обработки и печати документов, совершения звонков с помощьюIP-телефонов. Это неизбежный процесс, если предприятию необходима оптимизация всех рабочих процессов и увеличение прибыли.

Что дает локальная сеть?

Хорошая организация локальной сети дает возможность предприятию получить в распоряжение скоростной канал передачи и обмена информации. Она объединяет в себе большое количество рабочих узлов-компьютеров, главный сервер и периферийные устройства. Локальная сеть в офисе или группе офисов значительно повышает эффективность и производительность работы предприятия. Она обеспечивает сотрудников непрерывным совместным доступам ко всем ресурсам сети, выходом в Интернет, предоставляет в пользование все периферийные устройства. Сеть дает возможность удобного и оперативного обмена данными между сотрудниками. Таким образом, локальная сеть делает более эффективным электронный документооборот, программа для которого доступна одновременно всем сотрудникам. Грамотная организация сети повышает безопасность корпоративных информационных ресурсов повышенной секретности, делает возможным экономить время и бюджет для организации новых рабочих мест и модернизации сети, дает возможность одновременно управлять всеми рабочими узлами.

1 АНАЛИЗ УЧИТЫВАЕМЫХ ИНФОРМАЦИОННЫХ

  РЕСУРСОВ И СИСТЕМ ОБЪЕКТА

При проектировании локальной сети предприятия нужно учитывать цели, которые ставит заказчик. В нашем случае, основная цель — создать коммуникационную сеть, объединяющую все компьютеры и периферийные устройства на одном этаже, которые имеют доступ во внешнюю сетьInternet. К второстепенным целям относятся развертываниеweb-сервера, сервера для хранения файлов (FTP-сервер) и почтового сервера.

Предприятие имеет несколько отделов:

  • информационных технологий
  • дизайна
  • финансовый
  • оптимизации бизнес процессов
  • производства
  • закупок
  • корпоративный юридический
  • директорская
  • конролинга
  • персонала
  • логистики
  • маркетинга

Так же отдельно можно выделить серверную комнату, в которой будет размещать коммутационное оборудование и сервера.

При этом следует отметить, что необходимо организовать разграничение прав и ролей для всех категорий пользователей.

При проектировании были использованы следующие нормативно-технические документы:

схемы размещения оборудования:включает в себя указание на размещения оборудования, а также необходимых площадей и проходов для обслуживания технических средств;

схемы размещения проводки: электрические провода и кабели (с указанием их номера, типа, длины и, при необходимости, мест подсоединения), прокладываемые вне щитов и кроссовых шкафов, а также технические характеристики кабелей и проводов, предусмотренных данной схемой, и необходимое их число;

таблицы соединений: таблица подключений кабелей и проводов;

таблицы размещений: таблица примененных в схеме условных обозначений, не предусмотренных действующими стандартами;

сборочные чертежи (включая коммутационные шкафы и панели): сборочные чертежи коммутационных шкафов, которые предназначены для удобного, компактного, технологичного и безопасного крепления телекоммуникационного оборудования - серверов, маршрутизаторов, модемов, станций;

топология СКС -«иерархическая звезда»,допускающая дополнительные соединения распределительных пунктов одного уровня.

Среди них можно выделить следующие стандарты:

TIA/EIA-568A -стандарт телекоммуникационного кабрирования коммерческих зданий;

ISO/IEC 11801 -стандарт, определяющий структуру и параметры слаботочных кабельных систем, устанавливаемых в одном, нескольких или комплексе зданий;

ISO/IEC 24764 - стандарт, определяющий общую кабельную систему для информационных центров;

EN 50173:2007 - европейский стандарт СКС для офисов, промышленных помещений, домов и центров обработки данных базируются на единой основе;

ГОСТ 28601.2-90 - «Система несущих конструкций серии 482,6 мм. Шкафы и стоечные конструкции. Основные размеры»;

ГОСТ 24.206-80 - требования к содержанию документов по техническому обеспечению;

РД 50-34.698-90 Автоматизированные системы. Требования к содержанию документов.

Очерёдность создания системы следующая:

1Создание структурной схемы и конфигурация рабочих мест: в него входит расположение рабочих мест на плане здания и их взаимодействие между собой, подключение рабочих мест к сети;

2Выбор перечня оборудования разного уровня будет происходить таким образом, чтобы оно ни коим образом не влияло быстродействие сети, и любая передача информации происходила в комфортных для каждого сотрудника условиях, а также для защиты и резервирования данных предприятия;

Для этого была создана иерархическая модель сети -трехуровневая модель организации сети компании, впервые предложенная инженерамиCiscoSystems, на которых решаются различного рода задачи:

уровень ядра -обеспечивает резервирование каналов и высокоскоростную передачу данных между различными сегментами уровня распределения.В нашем случае эти функции выполняет маршрутизатор.

уровень распределения - решаются задачи маршрутизации, фильтрации и настройки QoS. В нашем случае эти функции выполняют коммутаторы L3.

уровень доступа - служит для подключения рабочих станций и серверов к сети компании. В нашем случае эти функции выполняют коммутаторы L2.

3 Выбор среды передачи сигнала и методы прокладки кабеля.

На физическом уровне для физических кабелей определяются механические и электрические (оптические) свойства среды передачи, которые включают:

тип кабелей и разъемов;

разводку контактов в разъемах;

схему кодирования сигналов для значений 0 и 1.

Канальный уровень определяет доступ к среде и управление передачей посредством процедуры передачи данных по каналу. В локальных сетях протоколы канального уровня используются компьютерами, мостами, коммутаторами и маршрутизаторами. В компьютерах функции канального уровня реализуются совместными усилиями сетевых адаптеров и их драйверов.

Среда передачи сигнала будет происходить посредством неэкранированной витой пары пятой категории UTP-5e. Подключение непосредственно будет происходить при помощи разъёма 8P8C (RJ45).

Так как в здании используются подвесные потолки, то проводка кабеля будет происходить через них. При этом проявляется надежная защита от повреждений и защита от прикосновений.

2 ВЫБОР И ОБОСНОВАНИЕ ТОПОЛОГИИ             КОМПЬЮТЕРНОЙ СЕТИ И ПРИМЕНЯЕМЫХ СТАНДАРТОВ

Для уяснения различий между логической и физической топологиями сети, необходимо рассмотреть два нижних уровня эталонной модели взаимосвязи открытых систем (ISO/OSI): физический (physicallayer) и канальный (data-linklayer). При этом следует учитывать то, что канальный уровень имеет свои подуровни: управления доступом к среде (MAC - MediaAccessControl) и управления логическим каналом (LLC - LogicalLinkControl). Именно на физическом и канальном уровнях определяется топология сети, которая, в соответствии с этими уровнями, может быть физической и логической.

Логическая топология представляет собой логическую структуру сети. Такая схема определяет, как элементы сети взаимодействуют между собой, как передается информация в сети, и какой путь она при этом преодолевает.

Физическая топология определяет расположение монтажных соединений сети. Она задает схему соединения элементов сети между собой (имеются в виду электрические соединения). Физическая топология определяет, что произойдет в сети при выходе из строя какого-либо узла.

Различают три основных вида топологии:

1) Звезда;

2) Кольцо;

3) Шина.

Каждая из этих топологий имеет как свои преимущества, так и недостатки, самыми важными из которых являются небольшая производительность и, в случае отказа главного элемента, отказ работы всей сети.

Дерево - самая распространенная и верная топология. Такая сеть организована по принципу централизованного обращения, т.е. есть центральный компьютер или коммутатор, к которому подключены все компьютеры сети.

Эта топология, известная также как распределенная шина или ветвящееся дерево, является гибридной физической топологией, объединяющей свойства топологии звезды и общей шины. Несколько шин могут быть объединены в шлейф либо шины могут ответвляться от места их соединений концентраторов. Начальный пункт дерева, образуемый шинами, называется корнем, или головным узлом. Примером такой топологии может служить организация системы, изображённая на рисунке 2.1.

Рисунок 2.1 – Топология дерево

Преимущества топологии дерева:

легко расширяется;

легко обнаруживается неисправность.

Недостатки:

выход из строя корневого узла означает выход из строя всей системы;

выход из строя концентратора - выход из строя его ветвей;

если сеть очень большая, то доступ к ней затруднен.

Другим примером древовидной структуры является вариант звездообразной иерархической структуры. Это еще раз свидетельствует о том, что каждая из смешанных топологий может быть получена из базовых топологий различными способами.

Дерево может быть активным, или настоящим, и пассивным. При активном дереве в центрах объединения нескольких линий связи находятся центральные компьютеры, а при пассивном - концентраторы (хабы). Применяется достаточно часто и комбинированная топология, например, звездно шинная, звездно кольцевая.

Применяемые стандарты:

IEEE 802.3u (100BASETX)

IEEE 802.3ab (1000BASE – T)

IEEE 802.3ad (Агрегацияканалов)

IEEE 802.1q (VLAN)

RFC 2131 (DHCP)

RFC 1631 (NAT)

IEEE 802.1d (Spanning Tree Protocol)

–IEEE 802.3at-2009 (Power over Ethernet)

3 ВЫБОР И ОБОСНОВАНИЕ АКТИВНОГО И ПАССИВНОГО СЕТЕВОГО ОБОРУДОВАНИЯ

Для проектируемой сети требуется 5 коммутаторовL2, которые имеют по 24 портаFastEthernet, 2 коммутатораL3 по 8 портов минимум, 1 маршрутизатор для связи с внешней сетью.

Для предприятия было выбрано оборудование компании «Cisco»: маршрутизатор серии 7201, коммутаторы третьего уровня Catalyst3560-12PC и коммутаторы второго уровня SF220-24. Представленное оборудование подходит для локальных сетей доступа предприятий и филиалов.

Таблица 3.1 – Перечень активного сетевого оборудования

Позиционный номер

Тип оборудования

Модель

Количество

Назначение

R1

Маршрутизатор

7201

1

Обеспечения связи сWAN

S1-S5

КоммутаторL2

SF220-24

5

Маршрутизация трафика междуVLAN

SW1, SW2

КоммутаторL3

Catalyst3560-12PC

2

Обеспечение подключения конечных устройств кLAN

Таблица 3.2 – Перечень пассивного сетевого оборудования

Тип оборудования

Модель

Количество

Назначение

1

2

3

4

Монтажный шкаф

Cabeus 19”, 60x60x100см

1 шт.

Для размещения сетевого оборудования

Розетка внешняяRJ-45cat. 5е

Cabeus

100 шт.

Для подключения оборудования

Патч-корд,0.5м

Cabeus

15 шт.

Подключения одного электрического устройства к другомуили к пассивному оборудованию передачи сигнала

Продолжение таблицы 3.2

Кабель-канал ПВХ 12х7

Legrand

30м

Для прокладки кабеля

Кабель-канал ПВХ 32х16

Legrand

50м

Для прокладки кабеля

Кабель-канал ПВХ 40х16

Legrand

40м

Для прокладки кабеля

Кабель-канал ПВХ 60х40

Legrand

10м

Для прокладки кабеля

Кабель-канал ПВХ 80х40

Legrand

20м

Для прокладки кабеля

Кабель,UTP-5e

Cabeus UTP-1P-Cat.5e-SOLID

3100м

Для прокладки сети

Стяжка пластиковая нейлоновая

Legrand

250 шт.

Для стягивания кабеля в кабель-канале

Более детально рассмотрим выбранное сетевое оборудование от компании «Cisco».

МаршрутизаторCisco 7201 представлен на рисунке 3.1:

Рисунок3.1 — Маршрутизатор серии 7201

Функции:

  • Обеспечивает в два раза большую производительность по сравнению с маршрутизатором Cisco 7301 — до 2 миллионов пакетов в секунду в CiscoExpressForwarding (CEF)
  • Имеет четыре встроенных порта GigabitEthernet (GE)
  • Имеет один порт Ethernet 10/100 Мбит/с, предназначенный для управления
  • Имеет один USB-порт для подключения устройств хранения данных или маркера доступа
  • Имеет один порт адаптера Cisco 7000 серии

Сетевые особенности:

  • WAN-протоколы:Staric IP/Routing, Dynamic IP/DHCP, PPPoE, PPPtP, NAT, PAT
  • LAN-сервисы:802.1q
  • Протоколы маршрутизации:BGP, EIGRP, OSPF, RIPv1, RIPv2
  • QoS:L2 ToS, FIFO, RSVP, Priority Queuing, Custom Queuing, Weighted Fair Queuing, Class Based Weighted Fair Queuing
  • Управление: SSH, Telnet, RSH, SNMP, RADIUS, WEB-интерфейс
  • Сетеваябезопасность: IP Security, Stateful Firewall

КоммутаторL3Catalyst3560-12PC представлен на рисунке 3.2.

Рисунок 3.2 — КоммутаторL3Catalyst3560-12PC

Основные особенности:

  • Высокоскоростная маршрутизация трафика: благодаря технологии CiscoExpressForwarding (CEF) серия Catalyst 3560 обеспечивает высокопроизводительную маршрутизацию трафика IP. Программное обеспечение SMI поддерживает статическую, RIPv1 и RIPv2 маршрутизацию, а EMI – еще и OSPF, IGRP, EIGRP, а также маршрутизацию multicast трафика (PIM, DVMRP, IGMP snooping).
  • Высокаябезопасность:поддержкапротокола 802.1x, функциональностьIdentity-BasedNetworkingServices (IBNS), спискидоступадлятрафика, коммутируемогонавторомуровне (VLANACL), натретьемичетвертомуровнях (RouterACL), атакжеPort-basedACLs (PACL) иTime-basedACL. Для обеспечения безопасности при администрировании поддерживаются протоколы SSH и SNMPv3, а также централизованная аутентификация на TACACS+ и RADIUS серверах.
  • Высокая доступность: для защиты от сбоев внутренних блоков питания коммутаторыCatalyst 3560 поддерживают резервную систему питанияCiscoRedundantPowerSystem 675 (RPS 675), протоколы 802.1D, 802.1s, 802.1w, функциональностьUplinkFast,HSRP,UDLD,AggressiveUDLD,SwitchportAuto-recovery.
  • Поддержка качества обслуживания (QoS):классификация трафика по полям DSCP или 802.1p (CoS), стандартные и расширенные списки доступа для выделения заданного типа трафика, WRED, очередность StrictPriority, ShapedRoundRobin. Существует возможность определения максимальной полосы для определенного вида трафика, а также выделения гарантированной полосы CIR.
  • Отличная управляемость:внедренное в коммутатор ПО Cisco CMS, поддержка управления с помощью SNMP-платформ, таких как CiscoWorks, поддержка SNMP версий 1, 2, 3, Telnet, RMON, SPAN, RSPAN, NTP, TFTP.

Основные характеристики

  • 12 x RJ-45 Ethernet 10/100
  • 1 x RJ-45 10/100/1000BASE-T
  • 1 x SFP 1000BASE-T
  • Матрица коммутации: 32 Гбит/с
  • Производительность маршрутизации 38,7 млн. пакетов/c
  • Неблокируемый (Wire-speed производительность)
  • Тип поддерживаемых транков 802.1q или ISL
  • Тип поставляемого ПО - EMI или SMI

КоммутаторL2 представлен на рисунке 3.3:

Рисунок 3.3 — КоммутаторL2SF220-24

Особенности:

  • Высокий уровень безопасности:

ACLs и flow-basedQoS предоставляет новый уровень контроля и производительности сети.

  • Простое и гибкое управление:

коммутаторы Cisco 220 просты в установке и использовании, возможность самостоятельного развертывания сети без привлечения ИТ-специалистов. Эти коммутаторы предоставляют больше возможностей управления, как Cisco CLI, протокол сетевого управления (SNMP), интеграция с системой CiscoPrime ™ LAN Management (LMS), кроме того интуитивный веб-интерфейс и поддержка утилиты CiscoFindIt.

  • Поддержка питания по сети Poe/PoE+:

PoE + упрощает развертывание беспроводных точек доступа, IP-телефонии, и видеонаблюдения, благодаря предоставлению питание и данных в одном сетевом кабеле. Дополнительно Cisco 220 поддерживают технологию PoE + на отдельных портах, что составляет до 30 Вт мощности на каждый порт.

4 АДРЕСАЦИЯ В ПРОЕКТИРУЕМОЙ СЕТИ

На предприятии расположено 13 отделов, каждый из которых имеет собственныйVLAN и подсеть.

Таблица 4.1 – Адресация в проектируемой сети

Объект

IP-адрес

Описание

Характеристика

1

2

3

4

Сеть 1

192.168.10.0/27

Диапазон адресов:

192.168.10.1 – 192.168.10.30

Broadcast: 192.168.10.31

3подсети

Подсеть 1

192.168.10.0/28

Диапазон адресов:

192.168.10.1 – 192.168.10.14

Broadcast: 192.168.10.15

Занято: 12 адресов

На расширение: 2 адреса

VLAN 30

192.168.10.1

Финансовый отдел

Подсеть 2

192.168.10.16/29

Диапазон адресов:

192.168.10.17 – 192.168.10.22

Broadcast: 192.168.10.23

Занято: 4 адреса

На расширение: 2 адреса

VLAN10

192.168.10.17

Отдел инф. технологий

Подсеть 3

192.168.10.24/29

Диапазон адресов:

192.168.10.25 – 192.168.10.30

Broadcast: 192.168.10.31

Занято: 3 адреса

На расширение: 3 адреса

VLAN20

192.168.10.25

Отдел дизайна

Сеть 2

192.168.20.0/27

Диапазон адресов:

192.168.20.1 – 192.168.20.30

Broadcast: 192.168.20.31

3подсети

Подсеть 4

192.168.20.0/28

Диапазон адресов:

192.168.20.1 – 192.168.20.14

Broadcast: 192.168.20.15

Занято: 12 адресов

На расширение: 2 адреса

Продолжение таблицы 4.1

VLAN60

192.168.20.1

Отдел закупок

Подсеть 5

192.168.20.16/29

Диапазон адресов:

192.168.20.17 – 192.168.20.22

Broadcast: 192.168.20.23

Занято: 4 адреса

На расширение: 2 адреса

VLAN40

192.168.20.17

Отдел оптимизации бизнес процессов

Подсеть 6

192.168.20.24/29

Диапазон адресов:

192.168.20.25 – 192.168.20.30

Broadcast: 192.168.20.31

Занято: 3 адреса

На расширение: 3 адреса

VLAN50

192.168.20.25

Отдел производства

Сеть 3

192.168.30.0/26

Диапазон адресов:

192.168.30.1 – 192.168.30.62

Broadcast: 192.168.30.63

2подсети

Подсеть 7

192.168.30.0/27

Диапазон адресов:

192.168.30.1 – 192.168.30.30

Broadcast: 192.168.30.31

Занято: 18 адресов

На расширение: 12 адресов

VLAN70

192.168.30.1

Отдел производства

Подсеть 8

192.168.30.32/29

Диапазон адресов:

192.168.30.33 – 192.168.30.38

Broadcast: 192.168.30.39

Занято: 3 адреса

На расширение: 3 адреса

VLAN80

192.168.30.33

Сервера

Сеть 4

192.168.40.0/27

Диапазон адресов:

192.168.40.1 – 192.168.40.30

Broadcast: 192.168.40.31

3подсети

Продолжение таблицы 4.2

Подсеть 9

192.168.40.0/28

Диапазон адресов:

192.168.40.1 – 192.168.40.14

Broadcast: 192.168.40.15

Занято: 10 адресов

На расширение: 4 адреса

VLAN100

192.168.40.1

Отдел контролинга

Подсеть 10

192.168.40.16/28

Диапазон адресов:

192.168.40.17 – 192.168.40.30

Broadcast: 192.168.40.31

Занято: 6 адресов

На расширение: 8 адресов

VLAN110

192.168.40.17

Отдел персонала

Подсеть 11

192.168.40.32/29

Диапазон адресов:

192.168.40.33 – 192.168.40.38

Broadcast: 192.168.40.39

Занято: 4 адреса

На расширение: 2 адреса

VLAN90

192.168.40.33

Директорская

Сеть 5

192.168.50.0/27

Диапазон адресов:

192.168.50.1 – 192.168.50.30

Broadcast: 192.168.50.31

2подсети

Подсеть 12

192.168.50.0/28

Диапазон адресов:

192.168.50.1 – 192.168.50.14

Broadcast: 192.168.50.15

Занято: 10 адресов

На расширение: 4 адреса

VLAN120

192.168.50.1

Отдел логистики

Подсеть 13

192.168.50.16/28

Диапазон адресов:

192.168.50.17 – 192.168.50.30

Broadcast: 192.168.50.31

Занято: 9 адресов

На расширение: 5 адресов

VLAN130

192.168.50.17

Отдел маркетинга

Файловый сервер

192.168.30.34

Почтовый сервер

192.168.30.35

Веб-сервер

192.168.30.36

Все конечные устройства получаютIP-адрес, маску и шлюз по умолчанию при помощи протоколаDHCP, который настроен на двух коммутаторахL3: каждыйVLANполучает свой пул адресов исходя из подсетей, указанных в таблице.

5 МАРШРУТИЗАЦИЯ В ПРОЕКТИРУЕМОЙ СЕТИ

В современных сетяхVLAN — главный механизм для создания логической топологии сети, не зависящей от её физической топологии.VLAN'ы используются для сокращения широковещательного трафика в сети. Имеют большое значение с точки зрения безопасности, в частности как средство борьбы сARP-spoofing'ом. Устройства, находящиеся в разных VLAN'ах, невидимы друг для друга на канальном уровне, даже если они подключены к одному коммутатору, и связь между этими устройствами возможна только на сетевом и более высоких уровнях.

Процесс маршрутизации на 3-м уровне можно осуществлять с помощью маршрутизатора или коммутатора 3-го уровня. Использование устройства 3-го уровня обеспечивает возможность управления передачей трафика между сегментами сети, в том числе сегментами, которые были созданы с помощью VLAN.

После того, как интерфейсы с прямым подключением настроены и добавлены в таблицу маршрутизации, можно приступить к реализации статической или динамической маршрутизации.

В нашем конкретном случае мы настраивали статическую маршрутизацию по умолчанию на коммутаторахL3.

Статические маршруты настраиваются вручную. Они определяют точный маршрут между двумя сетевыми устройствами. В отличие от протокола динамической маршрутизации, статические маршруты не обновляются автоматически, и при изменениях в сетевой топологии их нужно настраивать вручную.

К преимуществам статической маршрутизации можно отнести:

  • настройки (в небольших сетях),
  • отсутствие дополнительной нагрузки на сеть (в отличии от динамических протоколов маршрутизации).

К недостаткам относится:

  • сложность масштабирования,
  • при возникновении каких-либо изменений в сети, как правило потребуется вмешательство администратора и настройка новых, актуальных статических маршрутов,
  • если возникают проблемы на канальном уровне, но интерфейс по-прежнему в статусе up, то статический маршрут остается активным, хотя фактически данные передаваться не могут.

В таблице маршрутизации представлены два распространённых типа статических маршрутов:

статические маршруты в конкретную сеть;

статические маршруты по умолчанию.

Статические маршруты для конкретной сети настраиваются с помощью команды глобальной конфигурации:

iproutenetworkmask {next-hop-ip |exit-intf}

Статический маршрут определяется в таблице маршрутизации посредством кода «S».

Чтобы направить пакеты адресованные в сети, которые явно не указаны в таблице маршрутизации используется маршрут по умолчанию (Defaultroute). Маршруты по умолчанию доступны в топологиях, где не желательно изучение более специфичных сетей, как в случае, конечных тупиковых сетей (stubnetwork) или когда количество системных ресурсов ограничено.

Для настройки маршрута по умолчанию используется команду глобальной конфигурации:

ip route 0.0.0.0 0.0.0.0 {exit-intf | next-hop-ip}

6 РАСЧЁТОСНОВНЫХЧИСЛОВЫХХАРАКТЕРИСТИКПРОЕКТИРУЕМОЙ СЕТИ

Рассчитаем потребляемую мощность:

сеть представлена одним маршрутизатором сmax. мощностью 150 Вт

1 * 150 Вт = 150 Вт

двумя коммутаторами уровня распределения

2*204 Вт = 408 Вт

пятью коммутаторами уровня доступа

5 * 9,2 Вт = 46 Вт

Итого суммарная потребляемая мощность составляет 604 Вт.

Портовая ёмкость сети состоит из пяти коммутаторов уровня доступа:

5 = 120 портов

Для упрощения расчета PDV (время двойного оборота сигнала) обычно используются справочные данные IEEE, содержащие значения задержек распространения сигналов в повторителях, приемопередатчиках и различных физических средах. В таблице 4 приведены данные, необходимые для расчета значения PDV для всех физических стандартов сетей Ethernet.

Левый сегмент - это передающий сегмент. Затем сигнал проходит через промежуточные сегменты и доходит до наиболее удаленного правого (принимающего) сегмента. Именно здесь в худшем случае происходит столкновение кадров и возникает коллизия.

С каждым сегментом связана постоянная задержка, названная базой, которая зависит только от типа сегмента и от положения сегмента на пути сигнала (левый, промежуточный или правый). Кроме того, с каждым сегментом связана задержка распространения сигнала вдоль кабеля сегмента, которая зависит от длины сегмента и вычисляется путем умножения времени задержки сигнала на одном метре кабеля (в битовых интервалах) на длину кабеля в метрах.

Таблица6.1 -PDVвсетиEthernet

Расчёт PDV выполняется для двух наиболее удаленных (по времени распространения сигнала) станций сети и заключается в вычислении задержек, вносимых каждым отрезком кабеля, и суммировании этих задержек с базами левого, промежуточных и правого сегментов. Общее значение PDV (сумма значений всех сегментов) не должно превышать 575 битовых интервалов. Это значение получено, исходя из минимальной длины кадра в 10-мегабитном Ethernet в 64 байта плюс преамбула 8 байт, всего 72 байта или 576 бит. Следовательно, время двойного оборота должно быть меньше 57,5 мкс.

Так как левый и правый сегменты имеют различные величины базовой задержки, необходимо выполнить расчеты дважды, поменяв при втором расчёте местами левый и правый сегменты сети.

Для расчёта конфигурации разработанной локальной сети определим наиболее удалённые узлы сети. В нашем случае ими являются узлы, находящиеся в отделе информационных технологий и в отделе маркетинга.

Расстояние между наиболее удаленными уздами этих отделов равно 80 метров. Таким образом, наиболее протяжённый участок сети состоит из двух коммутаторов, двух сетевых адаптеров, кабеля UTP-5e длиной 80 метров. Один метр витой пары категории 5 вносит задержку в 1,112 bt. Значит весь сегмент вносит задержку равную 1,112 80 = 88,96 bt, пара сетевых адаптеров дают задержку в 138 bt и два стека коммутаторов по 67 bt каждый. Общая задержка данного сегмента равна 400,96 bt.

Так как выполняется условие превышения задержки в 512 bt над PDV наибольшего сегмента сети, значит сеть спроектирована корректно, запас задержки составляет 111,04 bt.

Определим нагрузку на сеть.

Нагрузка на сеть – это объём данных, реально передаваемый по сети в единицу времени:

где D – суммарный объём данных, переданный за время t.

Нагрузку на сеть также можно определить, исходя из объёма данных в единицу времени  , приходящийся на одну рабочую станцию:

где n – число компьютеров в сети.

Расчет  нагрузки на один компьютер в сети осуществляется по формуле:

где D – суммарный объём данных, переданный за время t одной рабочей станцией.

При значенияхD = 10MB (среднее значение) иt = 60c нагрузка на один компьютер составит:

Тогда нагрузка на сеть составит:

Пропускная способность С – это максимально возможная для данной сети скорость передачи данных, которая определяется битовой скоростью и некоторыми другими ограничивающими факторами (длительность интервалов между передаваемыми блоками данных, объем передаваемой по сети служебной информации и др.). Значения пропускной способности для сетевых технологий известны и приводится в стандарте. В большинстве случаев можно принять пропускную способность равной битовой скорости.

С для стандарта 100BASE-TX составляет 100 Мбит/с = 12,5 МБ/с.

Коэффициент использования сети равен отношению нагрузки на сеть к пропускной способности. Коэффициент использования сети рассчитывается по формуле:

Подставив данные, получим:

Несмотря на то, что скорость передачи данных в сети определенной технологии всегда одна и та же, производительность сети уменьшается с увеличением объема передаваемых данных. Во-первых, объем передаваемых данных (трафик) делится между всеми компьютерами сети. Во-вторых, даже та доля пропускной способности разделяемого сегмента, которая должна приходиться на один узел, очень часто ему не достается из-за особенностей работы механизма доступа к общей среде передачи данных. После определенного предела увеличение коэффициента использования сети приводит к резкому уменьшению реальной скорости передачи данных. Потери времени, связанные с работой механизма доступа к разделяемой среде зависят от характера обращений компьютеров к сети и не могут быть точно рассчитаны, поэтому для обеспечения достаточной производительности задается предельное значение коэффициента использования сети, при котором сеть будет быстро реагировать на обращения пользователей.

7 МЕРОПРИЯТИЯ ПООБЕСПЕЧЕНИЮОТКАЗОУСТОЙЧИВОСТИИ БЕЗОПАСНОСТИ СЕТИ

Тема сетевой безопасности очень обширна в данное время.

Специалисты по проектированию сетей используют межсетевые экраны для обеспечения защиты сети от несанкционированного использования. Межсетевые экраны или брандмауэры представляют собой аппаратные или программные решения, направленные на повышение степени защищённости сети. Межсетевой экран фильтрует неавторизованные или потенциально опасные пакеты, предотвращая их проникновение в сеть. На маршрутизатореCisco можно настроить простой межсетевой экран, который позволяет фильтровать трафик на базовом уровне с помощью ACL-списков. Использование ACL-списков позволяет администраторам останавливать трафик или допускать в сеть только определённый трафик.

Список контроля доступа (ACL) — это последовательный список правил разрешения или запрета, применяемых по отношению к адресам или протоколам более высокого уровня. ACL-списки позволяют эффективно контролировать входящий и исходящий трафик сети. ACL-списки также можно настраивать для всех маршрутизируемых протоколов сети.

Самой важной причиной для настройки ACL-списка является обеспечение безопасности сети.

ACL-списки были настроены для серверов, чтобы доступ к ним имел лишь технический персонал. Остальные отделы будут иметь к ним доступ как к пассивному источнику.

Между коммутаторамиL3 было проложено 2 кабеля для обеспечения отказоустойчивости оборудования.

Для доступа к настройкам роутера был установлен пароль. Идеальный пароль – это длинная комбинация различных знаков, которая включает в себя не только буквы и цифры, а также знаки пунктуации и символы.

Для защиты от несанкционированного доступа, а также удалённого управления оборудования с зашифрованным трафиком, был настроен протокол прикладного уровняSSH. Так же был настроен удаленный доступ к роутеру только из подсети отдела информационных технологий.

8 МОДЕЛИРОВАНИЕПРОЕКТИРУЕМОЙКОМПЬЮТЕРНОЙСЕТИ

Очерёдность создания компьютерной сети в программеCiscoPacketTracer, представленная на рисункеy, была следующая:

– размещение необходимого оборудования;

созданиеVLAN на коммутаторах L2;

созданиеVLAN и их интерфейсов с последующим присваиванием имIP-адресов на коммутаторахL3;

перевод портов между коммутаторамиL2 иL3 в режимtrunk;

настройкаDHCP-сервера на обоих коммутаторахL3;

настройка статическихIP-адресов на серверах;

настройка маршрутизации междуVLAN при помощи статической маршрутизации по умолчанию на коммутаторахL3, маршрутизаторе и наWAN;

настройка динамическойNAT на маршрутизаторе;

настройка расширенныхACL-списков для ограничения доступа к серверам по определённым протоколам;

настройка протокола шифрованияSSH для обеспечения дополнительной защиты от несанкционированного доступа.

Рисунок 8.1 – Моделирование компьютерной сети в программеCiscoPacketTracer

СПИСОК ИСПОЛЬЗОВАННЫХ ИСТОЧНИКОВ

Продукты и решения компанииCisco[Электронный ресурс]. – Режим доступа:http://www.cisco.com/c/ru_ru/products/

 DHCP по VLAN на коммутаторах Cisco[Электронный ресурс]. – Режим доступа :https://habrahabr.ru/post/113431/

ПРИЛОЖЕНИЕ А

Таблица 1 – Расчет стоимости сети

Оборудование

Количество,шт.

Цена,$

Router Cisco 7201

1

3100

Switch L2 CiscoSF220-24

5

970

Switch L3 CiscoCatalyst 3560-12PC

2

2000

Монтажный шкафCabeus, 19”

1

255

Розетка внешняяRJ-45cat. 5е

100

115

Патч-корд,0.5м

15

12

Кабель канал ПВХ

150 м

25

Кабель,UTP-5e

3100 м

320

Стяжка пластиковая нейлоновая

250

1

Итоговая стоимость сети~ 6800$.

ПРИЛОЖЕНИЕ Б

Параметры конфигурации активного оборудования.

1. НастройкаVLANна коммутаторах.

СоздадимVLAN’ы и зададим им имена:

sw1(config)# vlan 2

sw1(config-vlan)# name vlan_name

Настроимaccess-порты:

sw1(config)# interface range fa0/4 - 5

sw1(config-if)# switchport mode access

sw1(config-if)# switchport access vlan 10

Настроимtrunk-порты:

sw1(config)# interface fa0/1

sw1(config-if)# switchport mode trunk

2. НастроимVLAN’ы на коммутаторахL3 и присвоим имIP-адреса.

СоздадимVLAN’ы и зададим им имена:

s1(config)# vlan 2

s1(config-vlan)# name vlan_name

Присвоим интерфейсамVLAN’овIP-адреса – адреса шлюза по умолчанию каждой подсети:

s1(config)# interface vlan 10

s1(config-if)# ip address 192.168.10.1 255.255.255.248

3. Переведем порты между коммутаторамиL2 иLtrunkрежим:

s1(config)# int fa0/1

s1(config)# sw mode trunk

4. НастроимDHCP на обоих коммутаторахL3.

РаздаватьIP-адреса будем исходя изVLAN’а, в котором находится устройство.

ВключаемIProutingи создаем пулыIP-адресов:

s1(config)#ip routing

s1(config)#ipdhcp pool v10

s1(dhcp-config)#network 192.168.10.0 255.255.255.240

Вкачествеdefault-routerукажемадресинтерфейсаvlan’a:

s1(dhcp-config)#default-router 192.168.10.1

5. Настроим статическую маршрутизацию на роутере иL3-коммутаторах.

Для настройки маршрута по умолчанию используется команду глобальной конфигурации:

r1(config)#ip route 0.0.0.0 0.0.0.0 {exit-intf | next-hop-ip}

Для маршрутизации между роутером иL3-коммутаторами используем команду:

r1(config)#ip route 10.0.0.0 255.255.255.0 {exit-intf | next-hop-ip}

6. Настроим статическиеIP-адреса на серверах.

ipaddress 192.168.30.34 255.255.255.248

7. Настроим динамическуюNATна маршрутизаторе.

Перед использованием динамической трансляции, нужно задать nat-пул внешних адресов:

R1(config)#ipnat pool GLOBAL 10.11.11.20 10.11.11.100 netmask 255.255.255.0

НастроимнепосредственноNAT:

R1(config)#ipnat inside source list 1 pool GLOBAL

8. На роутере настроимSSH-протокол.

Указываем домен и имя устройства (для генерации ключа):

r1(config)#ip domain name domain.local

r1 (config)#hostname r1-ssh

Генерируемключдля SSH:

r1-ssh(config)#crypto key generate rsa

Храним пароли в зашифрованном виде:

r1-ssh(config)#service password-encryption

Создаем пользователя admin с паролемParol_123 и максимальными привилегиями:

r1-ssh(config)#username admin privilege 15 secret Parol_123

Задаем пароль для привилегированного режима:

r1-ssh(config)#enable secret Parol_123

АктивируемпротоколААА:

r1-ssh(config)#aaa new-model

Разрешаем компьютерам внутренней сети заходить на Cisco по SSH:

r1-ssh(config)#access-list 23 permit 192.168.0.0 0.0.0.6

Входим в режим конфигурирования терминальный линий:

r1-ssh(config)#line vty 0 4

Запрещаемвсе,кроме SSH:

r1-ssh(config-line)#transport input ssh

Активируем автоматическое поднятие строки после ответа системы на проделанные изменения:

r1-ssh(config-line)#logging synchronous

Позволяем входить сразу в привилигированный режим:

r1-ssh(config-line)#privilege level 15

Настраиваем автоматическое закрытие SSH сессии через 60 минут:

r1-ssh(config-line)#exec-timeout 60 0

Привязываем группу доступа к терминальной линии:

r1-ssh(config-line)#access-class 23 in

9. Сделаем агрегирование каналов между коммутаторамиL3.

Перед настройкой агрегирования лучше выключить физические интерфейсы. Достаточно отключить их с одной стороны (в примере на s1), затем настроить агрегирование с двух сторон и включить интерфейсы.

НастройкаEtherChannelна s1:

s1(config)# interface range f0/7-8

s1(config-if-range)# shutdown

s1(config-if-range)# channel-group 1 mode on

НастройкаEtherChannelна s2:

s2(config)# interface range f0/7-8

s2(config-if-range)# channel-group 1 mode on

Включение физических интерфейсов наs1:

s1(config-if-range)# no sh

10. Настраиваем расширенные спискиACL на роутередля ограничения доступа к серверам извне.

Разрешаем доступ кFTP-серверу только по порту 21:

access-lists 120 per tcp any host 192.168.30.34 eq 21

Разрешаем доступ к почтовому серверу только по портам 25,465 и 587:

access-lists 120 per tcp any host 192.168.30.35 eq 25

access-lists 120 per tcp any host 192.168.30.35 eq 465

access-lists 120 per tcp any host 192.168.30.35 eq 587

Разрешаем доступ кWEB-серверу только по портам 80 и 443:

access-lists 120 per tcp any host 192.168.30.36 eq80

access-lists 120 per tcp any host 192.168.30.36 eq 443

Весь остальной траффик для серверов запрещаем:

access-lists 120 deny ip any host 192.168.30.34

access-lists 120 deny ip any host 192.168.30.35

access-lists 120 deny ip any host 192.168.30.36

Разрешаем прохождение пакетов, предназначенных другим устройствам:

access-lists 120 per ip any any

Применяем созданныйACL-список на портыG6/0 иG7/0 в направленииout:

int G6/0

ip access-lists 120 out

int G7/0

ip access-lists 120 out

Организация локальной сети на http://mirrorref.ru


Похожие рефераты, которые будут Вам интерестны.

1. Проектирование локальной сети

2. СКС – основа компьютерной локальной сети (ЛВС)

3. Проектирование локальной вычислительной сети

4. Разработка локальной сети магазина

5. Создание локальной вычислительной сети (ЛВС) для предприятия

6. Модель локальной сети на языке GPSS

7. Разработка локальной вычислительной сети и ДИС Матвеевской средней школы

8. Выбор топологии и строения сети. Выбор составляющих сети. Выбор комплектующих компьютеров. Нейронные сети

9. Анализ опасности трехфазной четырехпроводной сети с глухозаземленной нейтралью. Линейные и фазные напряжения в сети. Векторная диаграмма напряжений

10. Теорема о локальной ограниченности непрерывной функции